*FREE US SHIPPING

Garmin Connect App Minimum Device Software Requirements

The Garmin Connect app can be installed on an Android or iOS device. Devices must meet the following minimum requirements:

Android Requirements

  • 6.0 Operating System or later
    • Android version 6.0, (Android Marshmallow) was released in October 2015.  Most devices manufactured after this date will meet this requirement.

Apple iOS Requirements

  • iOS 12 or higher
    • Compatible with iPhone, iPad, iPod Touch
Sale

Unavailable

Sold Out